using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\bmy\b)(?=(?:[^""]|""[^""]*"")*$)";
string input = @"Hello my name is ""Tom, and my favourite sport is football"" my O my
Hello Tom, my name is Bonney
not mymymy
";
RegexOptions options = RegexOptions.Singleline | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}