const regex = /(\bmy\b)(?=(?:[^"]|"[^"]*")*$)/gsm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\bmy\\b)(?=(?:[^"]|"[^"]*")*$)', 'gsm')
const str = `Hello my name is "Tom, and my favourite sport is football" my O my
Hello Tom, my name is Bonney
not mymymy
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}