re = /(\bmy\b)(?=(?:[^"]|"[^"]*")*$)/m
str = 'Hello my name is "Tom, and my favourite sport is football" my O my
Hello Tom, my name is Bonney
not mymymy
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end