$re = '/(\bmy\b)(?=(?:[^"]|"[^"]*")*$)/sm';
$str = 'Hello my name is "Tom, and my favourite sport is football" my O my
Hello Tom, my name is Bonney
not mymymy
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);