import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\bmy\\b)(?=(?:[^\"]|\"[^\"]*\")*$)";
final String string = "Hello my name is \"Tom, and my favourite sport is football\" my O my\n"
+ "Hello Tom, my name is Bonney \n"
+ "not mymymy \n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}