# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!(?<!\S)\+)[0-9](?=[0-9]{4})/*/gm;t' <<< "test +13334445678 test"