$re = '/(?<!(?<!\S)\+)[0-9](?=[0-9]{4})/m';
$str = 'test +13334445678 test';
$subst = "*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;