const regex = /(?<!(?<!\S)\+)[0-9](?=[0-9]{4})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!(?<!\\S)\\+)[0-9](?=[0-9]{4})', 'gm')
const str = `test +13334445678 test`;
const subst = `*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);