re = /(?<!(?<!\S)\+)[0-9](?=[0-9]{4})/m
str = 'test +13334445678 test'
subst = '*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result