use strict;
my $str = 'test +13334445678 test';
my $regex = qr/(?<!(?<!\S)\+)[0-9](?=[0-9]{4})/mp;
my $subst = '*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";