#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{1,2}+[a-zA-Z]?+(?:,\d{1,2}+[a-zA-Z]?)*$"
Local $sString = "1" & @CRLF & _
"1," & @CRLF & _
"2A" & @CRLF & _
"2a" & @CRLF & _
"2a," & @CRLF & _
"2a:" & @CRLF & _
"2a,3" & @CRLF & _
"12" & @CRLF & _
"12c" & @CRLF & _
"12c" & @CRLF & _
"12c,1" & @CRLF & _
"12c,11v" & @CRLF & _
"12c,111" & @CRLF & _
"1,2,3,6A,6B,11,11A"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")