const regex = /^\d{1,2}+[a-zA-Z]?+(?:,\d{1,2}+[a-zA-Z]?)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{1,2}+[a-zA-Z]?+(?:,\\d{1,2}+[a-zA-Z]?)*$', 'gm')
const str = `1
1,
2A
2a
2a,
2a:
2a,3
12
12c
12c
12c,1
12c,11v
12c,111
1,2,3,6A,6B,11,11A`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}