use strict;
my $str = '1
1,
2A
2a
2a,
2a:
2a,3
12
12c
12c
12c,1
12c,11v
12c,111
1,2,3,6A,6B,11,11A';
my $regex = qr/^\d{1,2}+[a-zA-Z]?+(?:,\d{1,2}+[a-zA-Z]?)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}