import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{1,2}+[a-zA-Z]?+(?:,\\d{1,2}+[a-zA-Z]?)*$";
final String string = "1\n"
+ "1,\n"
+ "2A\n"
+ "2a\n"
+ "2a,\n"
+ "2a:\n"
+ "2a,3\n"
+ "12\n"
+ "12c\n"
+ "12c\n"
+ "12c,1\n"
+ "12c,11v\n"
+ "12c,111\n"
+ "1,2,3,6A,6B,11,11A";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}