$re = '/^\d{1,2}+[a-zA-Z]?+(?:,\d{1,2}+[a-zA-Z]?)*$/m';
$str = '1
1,
2A
2a
2a,
2a:
2a,3
12
12c
12c
12c,1
12c,11v
12c,111
1,2,3,6A,6B,11,11A';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);