using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=\[\[)
(?<=
{{[Ii]nfobox
(?(stack)(?!))
(?>
(?<-stack>\k<stack>)
|
(?<=(?<stack> {{ ) [^{]* ) }}
|
(?<=(?<stack>\[\[) [^\]]*) ]]
|
(?<!])] | (?<!\[)\[
|
(?<!})} | (?<!{ ){
|
[^[\]{}]
)+
)
\[\[
(?i:File|Image):[^[|\]]+\|
(?:[^[|\]]*\|)*
(?>
[^[\]{}]
|
\[(?!\[) | ](?!])
|
{ (?!{ ) | }(?!})
|
\[\[(?= [^\]]* (?<stack2>\]\]))
|
{{ (?= [^}]* (?<stack2> }} ))
|
(?<-stack2>\k<stack2>)
)*
(?(stack2)(?!))
\]\]";
string input = @"{{Infobox xyz
|aaa= Xyz
|bbb= [[Xyz]]
|ccc=[[File:xyz.jpg|thumb|Xyz.]]
|ddd= {{lang|en|xyz}}
|eee=[[File:xyz.jpg|thumb|Xyz.]]
|eee=[[File:xyz.jpg|thumb|Xyz. [[Link]] in caption.]]
}}
[[File:abc.jpg|thumb|Abc.]]
{{foo|[[File:abc.jpg|thumb|Abc.]]}}";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}