# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?=\[\[)
(?<=
{{[Ii]nfobox
(?(stack)(?!))
(?>
(?<-stack>\k<stack>)
|
(?<=(?<stack> {{ ) [^{]* ) }}
|
(?<=(?<stack>\[\[) [^\]]*) ]]
|
(?<!])] | (?<!\[)\[
|
(?<!})} | (?<!{ ){
|
[^[\]{}]
)+
)
\[\[
(?i:File|Image):[^[|\]]+\|
(?:[^[|\]]*\|)*
(?>
[^[\]{}]
|
\[(?!\[) | ](?!])
|
{ (?!{ ) | }(?!})
|
\[\[(?= [^\]]* (?<stack2>\]\]))
|
{{ (?= [^}]* (?<stack2> }} ))
|
(?<-stack2>\k<stack2>)
)*
(?(stack2)(?!))
\]\]
"""
test_str = ("{{Infobox xyz\n"
"|aaa= Xyz\n"
"|bbb= [[Xyz]]\n"
"|ccc=[[File:xyz.jpg|thumb|Xyz.]]\n"
"|ddd= {{lang|en|xyz}}\n"
"|eee=[[File:xyz.jpg|thumb|Xyz.]]\n"
"|eee=[[File:xyz.jpg|thumb|Xyz. [[Link]] in caption.]]\n"
"}}\n\n"
"[[File:abc.jpg|thumb|Abc.]]\n\n"
"{{foo|[[File:abc.jpg|thumb|Abc.]]}}")
matches = re.finditer(regex, test_str, re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.