use strict;
my $str = '{{Infobox xyz
|aaa= Xyz
|bbb= [[Xyz]]
|ccc=[[File:xyz.jpg|thumb|Xyz.]]
|ddd= {{lang|en|xyz}}
|eee=[[File:xyz.jpg|thumb|Xyz.]]
|eee=[[File:xyz.jpg|thumb|Xyz. [[Link]] in caption.]]
}}
[[File:abc.jpg|thumb|Abc.]]
{{foo|[[File:abc.jpg|thumb|Abc.]]}}';
my $regex = qr/(?=\[\[)
(?<=
{{[Ii]nfobox
(?(stack)(?!))
(?>
(?<-stack>\k<stack>)
|
(?<=(?<stack> {{ ) [^{]* ) }}
|
(?<=(?<stack>\[\[) [^\]]*) ]]
|
(?<!])] | (?<!\[)\[
|
(?<!})} | (?<!{ ){
|
[^[\]{}]
)+
)
\[\[
(?i:File|Image):[^[|\]]+\|
(?:[^[|\]]*\|)*
(?>
[^[\]{}]
|
\[(?!\[) | ](?!])
|
{ (?!{ ) | }(?!})
|
\[\[(?= [^\]]* (?<stack2>\]\]))
|
{{ (?= [^}]* (?<stack2> }} ))
|
(?<-stack2>\k<stack2>)
)*
(?(stack2)(?!))
\]\]/xp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}