const regex = new RegExp('(?=\\[\\[)
(?<=
{{[Ii]nfobox
(?(stack)(?!))
(?>
(?<-stack>\\k<stack>)
|
(?<=(?<stack> {{ ) [^{]* ) }}
|
(?<=(?<stack>\\[\\[) [^\\]]*) ]]
|
(?<!])] | (?<!\\[)\\[
|
(?<!})} | (?<!{ ){
|
[^[\\]{}]
)+
)
\\[\\[
(?i:File|Image):[^[|\\]]+\\|
(?:[^[|\\]]*\\|)*
(?>
[^[\\]{}]
|
\\[(?!\\[) | ](?!])
|
{ (?!{ ) | }(?!})
|
\\[\\[(?= [^\\]]* (?<stack2>\\]\\]))
|
{{ (?= [^}]* (?<stack2> }} ))
|
(?<-stack2>\\k<stack2>)
)*
(?(stack2)(?!))
\\]\\]', 'g')
const str = `{{Infobox xyz
|aaa= Xyz
|bbb= [[Xyz]]
|ccc=[[File:xyz.jpg|thumb|Xyz.]]
|ddd= {{lang|en|xyz}}
|eee=[[File:xyz.jpg|thumb|Xyz.]]
|eee=[[File:xyz.jpg|thumb|Xyz. [[Link]] in caption.]]
}}
[[File:abc.jpg|thumb|Abc.]]
{{foo|[[File:abc.jpg|thumb|Abc.]]}}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}