$re = '/(?=\[\[)
(?<=
{{[Ii]nfobox
(?(stack)(?!))
(?>
(?<-stack>\k<stack>)
|
(?<=(?<stack> {{ ) [^{]* ) }}
|
(?<=(?<stack>\[\[) [^\]]*) ]]
|
(?<!])] | (?<!\[)\[
|
(?<!})} | (?<!{ ){
|
[^[\]{}]
)+
)
\[\[
(?i:File|Image):[^[|\]]+\|
(?:[^[|\]]*\|)*
(?>
[^[\]{}]
|
\[(?!\[) | ](?!])
|
{ (?!{ ) | }(?!})
|
\[\[(?= [^\]]* (?<stack2>\]\]))
|
{{ (?= [^}]* (?<stack2> }} ))
|
(?<-stack2>\k<stack2>)
)*
(?(stack2)(?!))
\]\]/x';
$str = '{{Infobox xyz
|aaa= Xyz
|bbb= [[Xyz]]
|ccc=[[File:xyz.jpg|thumb|Xyz.]]
|ddd= {{lang|en|xyz}}
|eee=[[File:xyz.jpg|thumb|Xyz.]]
|eee=[[File:xyz.jpg|thumb|Xyz. [[Link]] in caption.]]
}}
[[File:abc.jpg|thumb|Abc.]]
{{foo|[[File:abc.jpg|thumb|Abc.]]}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);