using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<localPart>[\w.]+)@(?P<domain>[\w]+)(\.(?P<subDomain>[\w]{2,10}))+(\.(?P<TopLevelDomain>[\w]{2,6}))?(?#Verify e-mail address validity: <local-part>@<domain>.<top-level-domain>)";
string input = @"hello3.why@gmail.co.uk
contact@regex101.com
hello3.2.why@gmail.co.uk
contact@regex101.companion thisone@gmail.com
hi@some.me.jp.sj.com
not valid@brokenemail.com
jon.apple@somewhere.co.dn.uk
localpartgoeshere@foo.example.com
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}