import re
regex = re.compile(r"(?P<localPart>[\w.]+)@(?P<domain>[\w]+)(\.(?P<subDomain>[\w]{2,10}))+(\.(?P<TopLevelDomain>[\w]{2,6}))?(?#Verify e-mail address validity: <local-part>@<domain>.<top-level-domain>)", flags=re.IGNORECASE)
test_str = ("hello3.why@gmail.co.uk\n"
"contact@regex101.com\n\n"
"hello3.2.why@gmail.co.uk\n"
"contact@regex101.companion thisone@gmail.com\n"
"hi@some.me.jp.sj.com \n\n"
"not valid@brokenemail.com\n\n"
"jon.apple@somewhere.co.dn.uk\n\n\n\n"
"localpartgoeshere@foo.example.com\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")