re = /(?P<localPart>[\w.]+)@(?P<domain>[\w]+)(\.(?P<subDomain>[\w]{2,10}))+(\.(?P<TopLevelDomain>[\w]{2,6}))?(?#Verify e-mail address validity: <local-part>@<domain>.<top-level-domain>)/i
str = 'hello3.why@gmail.co.uk
contact@regex101.com
hello3.2.why@gmail.co.uk
contact@regex101.companion thisone@gmail.com
hi@some.me.jp.sj.com
not valid@brokenemail.com
jon.apple@somewhere.co.dn.uk
localpartgoeshere@foo.example.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end