// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(?P<localPart>[\w.]+)@(?P<domain>[\w]+)(\.(?P<subDomain>[\w]{2,10}))+(\.(?P<TopLevelDomain>[\w]{2,6}))?(?#Verify e-mail address validity: <local-part>@<domain>.<top-level-domain>)").unwrap();
let string = "hello3.why@gmail.co.uk
contact@regex101.com
hello3.2.why@gmail.co.uk
contact@regex101.companion thisone@gmail.com
hi@some.me.jp.sj.com
not valid@brokenemail.com
jon.apple@somewhere.co.dn.uk
localpartgoeshere@foo.example.com
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}