import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<localPart>[\\w.]+)@(?P<domain>[\\w]+)(\\.(?P<subDomain>[\\w]{2,10}))+(\\.(?P<TopLevelDomain>[\\w]{2,6}))?(?#Verify e-mail address validity: <local-part>@<domain>.<top-level-domain>)";
final String string = "hello3.why@gmail.co.uk\n"
+ "contact@regex101.com\n\n"
+ "hello3.2.why@gmail.co.uk\n"
+ "contact@regex101.companion thisone@gmail.com\n"
+ "hi@some.me.jp.sj.com \n\n"
+ "not valid@brokenemail.com\n\n"
+ "jon.apple@somewhere.co.dn.uk\n\n\n\n"
+ "localpartgoeshere@foo.example.com\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}