#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?=.*\d)(.*)([-.])(.*)"
Local $sString = "3370.01b" & @CRLF & _
"6510.01.b" & @CRLF & _
"m-5510.30" & @CRLF & _
"drm-2013-c-004914" & @CRLF & _
"" & @CRLF & _
"hello" & @CRLF & _
"sk8" & @CRLF & _
"mixed-up"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")