using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*\d)(.*)([-.])(.*)";
string input = @"3370.01b
6510.01.b
m-5510.30
drm-2013-c-004914
hello
sk8
mixed-up";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}