$re = '/(?=.*\d)(.*)([-.])(.*)/i';
$str = '3370.01b
6510.01.b
m-5510.30
drm-2013-c-004914
hello
sk8
mixed-up';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);