use strict;
my $str = '3370.01b
6510.01.b
m-5510.30
drm-2013-c-004914
hello
sk8
mixed-up';
my $regex = qr/(?=.*\d)(.*)([-.])(.*)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}