re = /(?=.*\d)(.*)([-.])(.*)/i
str = '3370.01b
6510.01.b
m-5510.30
drm-2013-c-004914
hello
sk8
mixed-up'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end