using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bfat(?: | \w+ )?bike\b";
string input = @"My father's fat bike is a fat tyre bike. #FatBike
My fat minibike
My father's fat, green, Schwinn bike";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}