const regex = /\bfat(?: | \w+ )?bike\b/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bfat(?: | \\w+ )?bike\\b', 'gmi')
const str = `My father's fat bike is a fat tyre bike. #FatBike
My fat minibike
My father's fat, green, Schwinn bike`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}