// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)\bfat(?: | \w+ )?bike\b").unwrap();
let string = "My father's fat bike is a fat tyre bike. #FatBike
My fat minibike
My father's fat, green, Schwinn bike";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}