$re = '/\bfat(?: | \w+ )?bike\b/mi';
$str = 'My father\'s fat bike is a fat tyre bike. #FatBike
My fat minibike
My father\'s fat, green, Schwinn bike';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);