re = /\bfat(?: | \w+ )?bike\b/mi
str = 'My father\'s fat bike is a fat tyre bike. #FatBike
My fat minibike
My father\'s fat, green, Schwinn bike'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end