#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:\\begin{align}|\G(?!\A))(?:(?!\\end{align})[^(])*\K\("
Local $sString = "(((" & @CRLF & _
"\begin{align}" & @CRLF & _
"\frac{d_l}{2}< |\epsilon_H(g(m))| <\frac{d_r}{2} " & @CRLF & _
"\frac{d_l}{2}< |\epsilon_H(g(m))| <\frac{d_r}{2} " & @CRLF & _
"\end{align}" & @CRLF & _
"((("
Local $sSubst = "\\left("
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)