use strict;
my $str = '(((
\\begin{align}
\\frac{d_l}{2}< |\\epsilon_H(g(m))| <\\frac{d_r}{2}
\\frac{d_l}{2}< |\\epsilon_H(g(m))| <\\frac{d_r}{2}
\\end{align}
(((';
my $regex = qr/(?:\\begin{align}|\G(?!\A))(?:(?!\\end{align})[^(])*\K\(/mp;
my $subst = '\\\\left(';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";