$re = '/(?:\\\\begin{align}|\G(?!\A))(?:(?!\\\\end{align})[^(])*\K\(/m';
$str = '(((
\\begin{align}
\\frac{d_l}{2}< |\\epsilon_H(g(m))| <\\frac{d_r}{2}
\\frac{d_l}{2}< |\\epsilon_H(g(m))| <\\frac{d_r}{2}
\\end{align}
(((';
$subst = "\\left(";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;