import Foundation
let pattern = #"(?:\\begin{align}|\G(?!\A))(?:(?!\\end{align})[^(])*\K\("#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
(((
\begin{align}
\frac{d_l}{2}< |\epsilon_H(g(m))| <\frac{d_r}{2}
\frac{d_l}{2}< |\epsilon_H(g(m))| <\frac{d_r}{2}
\end{align}
(((
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\\left("#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)