#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=Nurse$|Nursing.*(Coordinator|Specialist)$).*"
Local $sString = "Nursing Care Coordinator" & @CRLF & _
"Nursing Resource Coordinator" & @CRLF & _
"Nursing Practice Specialist" & @CRLF & _
"Nursing Professional Development Specialist" & @CRLF & _
"Nurse" & @CRLF & _
"Nurse's aid" & @CRLF & _
"Janitorial Specialist" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")