using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=Nurse$|Nursing.*(Coordinator|Specialist)$).*";
string input = @"Nursing Care Coordinator
Nursing Resource Coordinator
Nursing Practice Specialist
Nursing Professional Development Specialist
Nurse
Nurse's aid
Janitorial Specialist
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}