re = /^(?=Nurse$|Nursing.*(Coordinator|Specialist)$).*/m
str = 'Nursing Care Coordinator
Nursing Resource Coordinator
Nursing Practice Specialist
Nursing Professional Development Specialist
Nurse
Nurse\'s aid
Janitorial Specialist
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end