import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=Nurse$|Nursing.*(Coordinator|Specialist)$).*";
final String string = "Nursing Care Coordinator\n"
+ "Nursing Resource Coordinator\n"
+ "Nursing Practice Specialist\n"
+ "Nursing Professional Development Specialist\n"
+ "Nurse\n"
+ "Nurse's aid\n"
+ "Janitorial Specialist\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}