$re = '/^(?=Nurse$|Nursing.*(Coordinator|Specialist)$).*/m';
$str = 'Nursing Care Coordinator
Nursing Resource Coordinator
Nursing Practice Specialist
Nursing Professional Development Specialist
Nurse
Nurse\'s aid
Janitorial Specialist
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);