using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\.\d+)\s.+(?=_rev)|rev";
string substitution = @"";
string input = @"45.09 - WrapperA12_rev1.DXF";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}