import re
regex = re.compile(r"(?<=\.\d+)\s.+(?=_rev)|rev", flags=re.MULTILINE)
test_str = "45.09 - WrapperA12_rev1.DXF"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)