const regex = new RegExp('(?<=\\.\\d+)\\s.+(?=_rev)|rev', 'gm')
const str = `45.09 - WrapperA12_rev1.DXF`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);