re = /(?<=\.\d+)\s.+(?=_rev)|rev/m
str = '45.09 - WrapperA12_rev1.DXF'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result