$re = '/(?<=\.\d+)\s.+(?=_rev)|rev/m';
$str = '45.09 - WrapperA12_rev1.DXF';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;