#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?<=\D|\b)\d{6}(?=\D|\b)"
Local $sString = "123456" & @CRLF & _
"blab12345alabla" & @CRLF & _
" 123456" & @CRLF & _
"blab123456labla" & @CRLF & _
"blab1234567abla" & @CRLF & _
"blab123456"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")